Google has previously announced plans to depreciate Google Chrome’s trust in Symantec’s security certificates. This includes Symantec owned brands like Thawte, Verisign, Equifax, GeoTrust and Rapid SSL.

If any of your sites are using these site certificates, and if you do not replace them, your site will likely stop working in upcoming versions of Google Chrome. It is highly likely that this will be the case also for other browsers.

Zooma-Symantec

If your site is using an SSL/TLS certificate from Symantec issued before June 1, 2016, it will stop working with the upcoming version Google Chrome 66 released on April 17, 2018. Current Google Chrome version is 65.0.3325.xxx

To see if your site is already affected please review this blogpost from Google with recommended actions on how to rectify the situation.

If you have any questions about your site and if it is using the correct certificates, please reach out to us.

Get in touch with Zooma!

Anders Björklund

Founder, CEO & Strategist since 2001. Anders provides thoughts and reflections about what and how to think about onlinification and digitalisation in B2B. Asks a lot of questions, and knows what to do with the answers.
Find me on: